+ Reply to Thread
Page 2 of 11 FirstFirst 1 2 3 4 5 ... LastLast
Results 13 to 24 of 123
  1. #13
    Member Fo55il Knows a bit of info here and there Fo55il Knows a bit of info here and there
    Join Date
    Jul 2005
    Location
    Tai Land
    Car:
    Subaru Tai-berty
    def doing this asap

  2. #14
    Awesome DIY guide.... Thanks.

    Can i confirm the bulbs you used?

    I've been to Narva's website and the based on the photo of the packet the website has them listed as T6.5's or #27.

    What is the model of the climate control bulbs? Are they T5's or #26?

  3. #15
    ^^ i believe there T10's

    if you goto this ebay seller
    named pOoOo000Hbear (or sometihng) he sells lots of LED's and i did this to my car a long time ago
    pm me if u want the proper user name link ,but its something like that
    type led lights in ebay i guess!

  4. #16
    Member VTC-8OY has made a few knowledgable posts
    Join Date
    Dec 2004
    Location
    Sydney
    Car:
    EG5 + 10' Swift
    the bulb sizes on the gauge and climate control are same size - T5..

    T10s are too big to fit in the slot.

    I have the same setup in my car but i used blue leds, looks alright to me since im a ricer -_-

  5. #17
    i think they are t5, but im not really sure.. because i just got a mate to pick me up a few from his shop, and they are the numbers he told me

  6. #18
    Cool... i have to find myself some T5's

    So you didn't use the globes from the packet pictured here ?


  7. #19
    nah they were the wrong ones i picked up and didnt realize. and it was the only pic i took of them, so i just put it up

  8. #20
    Member Chriskoss has made a few knowledgable posts
    Join Date
    Mar 2009
    Location
    Shitnee
    Car:
    2 Door EK GLi
    Looks mad kyal bro! Good work

  9. #21
    Member Fo55il Knows a bit of info here and there Fo55il Knows a bit of info here and there
    Join Date
    Jul 2005
    Location
    Tai Land
    Car:
    Subaru Tai-berty
    ive got an eg6 cluster.

    i changed the globes to led ones and even ambered them.

    for sum reason they are really low and look lighter than the original ones.

    i realised that my the light dimmer isnt working anymore.

    any insight on that?

  10. #22
    Member SuiJin is an unknown quantity at this point
    Join Date
    Dec 2007
    Location
    Melbourne
    Car:
    1992 Del Sol
    just to let you know. u can buy bulb covers for $4 a pack.

  11. #23
    Quote Originally Posted by Fo55il View Post
    ive got an eg6 cluster.

    i changed the globes to led ones and even ambered them.

    for sum reason they are really low and look lighter than the original ones.

    i realised that my the light dimmer isnt working anymore.

    any insight on that?
    maybe the dimmer, because leds are a lot brighter then the bulbs
    so maybe the dimmers died on a low setting the thats whats stuffed you up. other than that i wouldn know what it would be

  12. #24
    Member Chriskoss has made a few knowledgable posts
    Join Date
    Mar 2009
    Location
    Shitnee
    Car:
    2 Door EK GLi
    Quote Originally Posted by Fo55il View Post
    ive got an eg6 cluster.

    i changed the globes to led ones and even ambered them.

    for sum reason they are really low and look lighter than the original ones.

    i realised that my the light dimmer isnt working anymore.

    any insight on that?
    I had some problem, bought red t5 LED's from ebay china.. they were too dim could barely see.. I just think its cuz they are cheap imitations and not up to spec for use within clusters.. I might change them to blue LED's.. but for the mean time I put the originals back in lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.3


Terms and Conditions
Ozhonda.com is in no way affiliated with the Honda motor company or Honda Australia in anyway whatsoever.